更新软件包

apt-get update

Gnome

由于 GNOME 3 有 Bug ,启动 VNC 服务器时 Session 崩溃,建议使用 mate、xfce 或者 lxde 桌面环境
安装
sudo apt-get install gnome tightvncserver
修改~/.vnc/xr改为下面的

1
2
3
4
5
6
7
8
9
10
11
12
13
14
#!/bin/sh
# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80×24+10+10 -ls -title “$VNCDESKTOP Desktop” &
gnome-session-fallback &
lxterminal &
/usr/bin/lxsession -s LXDE &

xfce

安装需要的包

apt-get install xfce4 xfce4-goodies gnome-icon-theme tightvncserver
如果你需要安装火狐的话apt-get install iceweasel
运行vncserver会让你输入密码并确认,最后会问你是否创建只供浏览的密码,根据需要即可
如果中文乱码的可以安装中文字体sudo apt-get install -y ttf-wqy-zenhei
没有终端的话可以安装xfce终端xfce4-terminal

lxde

apt-get install xorg lxde-core tightvncserver

中文乱码的话
apt-get install ttf-arphic-ukai ttf-arphic-uming ttf-arphic-gbsn00lp ttf-arphic-bkai00mp ttf-arphic-bsmi00lp
参考
https://www.digitalocean.com/community/tutorials/how-to-set-up-vnc-server-on-debian-8